Finder‐Lightroom‐Problem

Seit der neu­en Ver­si­on des Apple‐Betriebssystem OS X 10.5 Leo­pard sind Benut­zer des Profi‐Tools Ligh­troom von Ado­be mit einem Pro­blem kon­fron­tiert: Bil­der, wel­che in Ado­be Ligh­troom bear­bei­tet wur­den, kön­nen im Fin­der nicht mehr ange­zeigt wer­den. Beim Ver­such eine Vor­schau anzu­zei­gen bzw. die Bil­der in Cover­flow zu reprä­sen­tie­ren stürzt der Fin­der ab. Dies ist vor allem auch pro­ble­ma­tisch, wenn ent­spre­chen­de Bil­der her­un­ter gela­den wur­den und in dem Download‐Stapel des Docks lan­den. Hier befin­det man sich schnell in einer End­los­schlei­fe zwi­schen Absturz und Neu­start des Docks.

Das Pro­blem wird durch bestimm­te Meta­da­ten in der Exten­si­ble Meta­da­ta Plat­form von Ado­be ver­ur­sacht. XMP ist eins von vie­len Metadaten‐Formaten wel­che in Gra­fik­da­tei­en ein­ge­setzt wer­den und bie­tet den Vor­teil, dass belie­bi­ge Infor­ma­tio­nen dar­in abge­legt wer­den kön­nen. Kon­kret han­delt es sich dabei um ein For­mat zum Ein­bet­ten von RDF‐Daten (Resour­ce Descrip­ti­on Frame­work) in Binär­da­tei­en. Das For­mat wird bereits von allen aktu­el­len Adobe‐Produkten und eini­gen CMS‐Anbietern unter­stützt. Auch Ligh­troom spei­chert so zusätz­li­che Infor­ma­tio­nen ab, wel­che anschei­nend von der Core Gra­phics Biblio­thek des OS X 10.5.1 Betriebs­sys­tems nicht ver­stan­den wer­den. Lei­der führt dies in den meis­ten Fäl­len zum Absturz eini­ger Anwen­dun­gen, wel­che die­se Biblio­thek ein­set­zen. In dem hier beschrie­be­nen Fall ver­ab­schie­det sich der Fin­der.
Eine mög­li­che Lösung des Pro­blems besteht nun dar­in, dass alle XMP‐Metadaten wie­der kom­plett aus den Bil­dern ent­fernt wer­den. Wenn die digi­ta­le Kame­ra ihre Infor­ma­tio­nen in einem ande­ren Meta­da­ten­for­mat ablegt (z.B. EXIF, GPS, IPTC…) und man nicht auf die XMP‐Angaben in den Datei­en ange­wie­sen ist, stellt die­ser Vor­gang auch kein Pro­blem da. Aller­dings soll­te man vor der Bear­bei­tung logi­scher­wei­se ein Back­up sei­ner Medi­en anle­gen.
Ein sehr hilf­rei­ches Tool nennt sich Exif­Tool und kommt von Phil Har­vey. Hier­mit las­sen sich unter­schied­li­che Metadaten‐Formate in Medi­en aus­ge­ben und bear­bei­ten. In den Man­pages von Exif­Tool fin­det man auch schnell alle nöti­gen Para­me­ter sowie eini­ge Bei­spie­le für den Umgang mit die­sem Tool. Mit fol­gen­dem Befehl in der Kon­so­le kön­nen nun die XMP‐Metadaten rekur­siv aus allen Datei­en in einem Ver­zeich­nis und des­sen Unter­ver­zeich­nis­sen gelöscht wer­den:

exiftool ./ -xmp:All= -r -overwrite_original

Hier­bei haben die über­ge­be­nen Para­me­ter fol­gen­de Bedeu­tung:

  1. -xmp:All=
    XMP‐Tag aus der Datei kom­plett löschen.
  2. -r
    Rekur­siv durch alle Unter­ver­zeich­nis­se durch­ge­hen. Dies setzt vor­aus, dass die Über­ge­be­ne Datei‐Angabe ein Ver­zeich­nis ist (hier “./” für das aktu­el­le Ver­zeich­nis in der Kon­so­le).
  3. -over­wri­te
    Über­schreibt die ori­gi­na­le Datei (Back­up nicht ver­ges­sen!). Wird die­ser Para­me­ter weg­ge­las­sen, benennt das Exif­Tool die ori­gi­na­le Datei um, indem dem vor­han­de­nen Datei­na­me der String “_original” ange­hängt wird.

Lei­der brach­te das Update auf Ligh­troom 1.3 hier kei­ne Lösung, was auch ver­ständ­lich ist. XMP soll ja wei­ter­hin belie­bi­ge Meta­da­ten spei­chern kön­nen ohne dass Pro­gram­me oder Biblio­the­ken, wel­che nicht alle Anga­ben ver­ste­hen, sich ver­ab­schie­den. Bleibt nun nur noch die Hoff­nung, dass Apple hier bald eine Lösung in einem wei­te­ren Update lie­fert, nach­dem die OS X Ver­si­on 10.5.1 die­ses Pro­blem aus­ließ.

4

Kommentare

  1. Rolf  Dezember 16, 2007

    Hal­lo,
    vie­len Dank für den super Hin­weis — hat mich in mei­ner Ver­zweif­lung geret­tet!
    Noch als Ergän­zung: Wenn man nicht will, dass sich beim Neu­schrei­ben das Datei­da­tum ändert: -P als Para­me­ter mit setz­ten.
    (if do not want to chan­ge the last modi­fied date stamp of the file):
    exif­tool -P ./ -xmp:All= -r -overwrite_original
    Grü­ße!

    antworten
  2. Matthias Brusdeylins  Dezember 17, 2007

    Vie­len Dank für den Hin­weis !

    antworten
  3. Rolf  Februar 13, 2008

    Das Pro­blem ist mit dem Leo­pard Update 10.5.2 gelöst! Kein Pro­blem mehr bei mir!

    antworten
  4. Matthias Brusdeylins  Februar 13, 2008

    Ha, da war einer schnel­ler als ich 🙂
    Dan­ke für die Info!

    antworten

Lassen Sie eine Antwort, um Rolf
Klicken Sie hier, um die Antwort abzubrechen


Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.